
Appendix A:  Using the Microsoft Excel Spreadsheet Software

A-1 Fall 2004

In this course you will be using the Microsoft spreadsheet program Excel to work up most of
your data.  This handout is intended to help you to become familiar with some of Excel’s features.
One set of hardcopy manuals is also available in the computer lab; the entire manual is also using the
Help keys within Excel.

One important hint:  save early and save often!  This version of PowerMac (or possibly the UWL
network) has a tendency to freeze up, resulting in a loss of unsaved data.  Be sure to save your work
in your own folder inside the Student Files folder on the desktop.  

I. Creating the workbook and entering the data.

Excel can be started in several ways.  The most straightforward is to go to the MSOffice icon
near the upper right corner of the screen and click on it.  One of the options in the menu will be
Microsoft Excel (another is the word processing program Microsoft Word).  Highlight the Excel
option, and Excel will start up.  You may also start Excel from the Excel icon in the MSOffice folder
(which is in the Applications folder on the hard drive).  Your screen will come up with a new
workbook which looks something like this:

The main part of the page is occupied by a blank worksheet; there are actually 16 blank worksheets in
every workbook.  You can thumb through them using the tabs at the bottom of the screen.  When
you point your cursor to a button (picture) on the toolbar, the function of the button is shown on
the bottom of the screen (where it says “Ready” now).  Note the help button in the upper right of
the tool bar.  When you click once, you get a question mark which you can drag to click on anything
you want help with.  

You can create a new workbook using the New command in the File menu, or by using the
New icon in the tool bar (first icon on the left).  Once you have saved Excel files, you may open
them using the Open command under the File menu, or by using the Open icon in the tool bar
(second icon from the left).  

The tab keys will take you across rows.  You can also use the arrow keys to move around.
You can change the formatting of individual cells or entire rows or columns by selecting the portion
of the worksheet that you want to format, then choosing the Cells... option under the Format
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menu.  You will then have the option of numeric style, specifying alphabetical characters, etc.  I
suggest that you play with this as the need arises.  (Sometimes Excel has bizarre defaults).

Save your worksheet in your subfolder in the desktop folder
“Student Files” using the Save As... command in the File menu.
You may need to create a folder first with your name, or access your
folder on another computer.  All later saves within the same session
may be done using the Save command under the File menu, or by
using the save icon on the toolbar (the diskette).

II. Formatting the worksheet and sorting the data.

The formatting options on the toolbar are shown below, along with some instructions for using
some of the more useful formatting options.

Formatting the cells: Geneva is the default font.  You may change the font of the entire sheet by
selecting the entire sheet (click on the top left button of the sheet), then selecting the desired font
using the font pull-down menu (arrow near the current font window).  You may also change the
font in only selected cells.  The bold, italics and underline buttons will change the style of the type
in the cells.  (Note: Excel has a bug that makes typing in a bold or italic font very slow; so type first,
then change the font style).  There are also some fancy tools for making borders and shading cells
that you can find in the Format pull-down menu..

Resizing the cells:  If you highlight a column or a row, you can resize the cells in the highlighted
area by dragging the black separator bar in the row or column header.  Perhaps the easiest method
for resizing is the Autofit Selection... option in the Column... submenu of the Format menu.

Sorting data: Select the data ranges that you wish to sort (be sure to select all associated columns and
the column headers).  Choose Sort in the Data menu.  Note that Excel automatically interprets the
column headers.  

Decimal Places:  You can change the number of decimal places that are displayed using the
increase or decrease decimal places buttons on the toolbar.  It is your responsibility to present your
final worksheet with a realistic number of significant figures for all numbers.
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III. Manipulating Data in Excel

Inserting cells:  To insert a column, row or cells, select the cells that you want to insert near (for
example, select column A if you want to insert a column before column A).  In the Insert menu,
select the type of insertion that you want (row, column, cells, etc.)  You will be asked where to move
your selected cells.  

Entering a function:  Click on the button labeled “fx--”:  this invokes the Function Wizard.  You will
get a list of different functions that Excel knows.  If you select one of these, you will get a series of
dialog boxes telling you how to use the function.  

Example:  Using the function AVERAGE

• Click on the cell which will hold the value of AVERAGE (let us assume it is C13).  

• Select the function AVERAGE using the function wizard.  You will get a dialog box that asks for a
bunch of information.  Just hit “Finish”.  

• Look in the entry bar, and you will see “=AVERAGE(Number1, Number2, ...). The “=“ tells Excel that
you are going to perform some math, rather than just entering values.  Delete the values between the
parentheses.  

• Now specify the cells to be averaged by highlighting all of the values of xi.  Let us suppose that you
have data in cells C4 through C12.  If you highlight these cells, Excel will have typed C4:C12 within
the parentheses (the colon denotes a range).  When you hit return, Excel will calculate the average.  

Copying Information:  To save time, you can copy and paste the contents of a cell (or row or
column).  To copy, highlight the cells that you wish to copy, then press the “apple” and C keys
simultaneously.  To paste, place the cursor where you want the cells placed, and press “apple” and V.
When you copy and paste cells with formulas, you have to know about absolute and relative
addressing.

Absolute Addressing (e.g. $A$1) – Address does not change when copied

Relative Addressing (e.g. A1) -- Address changes when copied

Example:  Using Relative Addressing

• Select cell C13, which contains the formula “=AVERAGE(C4:C12)”.  

• Let us assume that you have data in cells D4 through D12.  Copy cell C13 and paste it
in cell D13.  

• You should now see in the entry bar: “=AVERAGE(D4:D12)”.  Excel has just used what
is called relative addressing.  Your initial formula told Excel to average all of the data
above the highlighted cell.  When you copied and pasted to create a new formula, Excel
used the data above the new cell to calculate the average.

Example:  Using Absolute Addressing

• Highlight cell C14, and enter the formula “=AVERAGE($C$4:$C$12)”.  

• Copy cell C14 and paste it in cell D14.  

• You should now see in the entry bar: “=AVERAGE($C$4:$C$12)”.  Excel has just used
what is called absolute addressing.  Your initial formula told Excel to average
specifically cells C4 through C12.  When you copied and pasted to create a new
formula, Excel used those same cells to calculate the average.

Absolute addressing can also be used for only the letter or only the number part of the address (i.e.
$C4, or C$4). You should experiment with the different types of addressing until you feel
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comfortable with them.  The appropriate use of relative and absolute addressing will be a great time
saver later in the course.

IV. Making Stacked Plots in Excel

This is an inelegant method, but will produce fairly nice stacked plots using Excel.

Initial Spreadsheet:  To begin, your spreadsheet should have columns of x,y data that you wish to
plot in a stacked fashion.  

Example:  To create a stacked plot of three NMR spectra (A, B, C), the spreadsheet should have the
format below, where eventually ppm=x-axis, Intensity=y-axis

Plotting the data:  

• Select the x,y data for set A and make a scatter plot.  Get rid of gridlines, markers, plot
background, etc., and change the line type to automatic.

• Double-click on the x-axis to get the Format Axis dialog box, then click on the Scale tab to
set the desired scale.  For spectra that have scales that run in reverse (NMR and IR spectra, for
example), click the Values in Reverse Order box.

• Click on the outside of the plot to select the whole plot, then pull down the Chart … Add
Data menu.  Highlight the data in set B, and click OK.  Select the following options in the
box that appears:

You should have the new set of data appear on your plot, but it will not yet be stacked
(offset) from the original data.  As for set A, get rid of markers, and change the line type to
automatic.  Repeat the whole process for other sets that you want on the same plot.
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Stacking the plots:  

You will now need to manually add an offset to the yvalues of any plots that you want offset relative
to the lowest one.  One way to do this is as follows:

• Determine the highest intensity (y-value) point in data set A.  Multiply it by ~1.5 as an initial
guess to a good offset value for set B.

• Insert a column next to the y column for set B, and enter an equation to add the offset value
to the enter an equation to add the offset value to the y value in the new column.

Example:  Offsetting spectrum B (assuming that the original Intensity_B data is in column D, and a
new, empty column is column E):

• In cell E1, you could enter "=D1+offset ", where offset is the value that you just calculated as a
first guess.

• Copy and paste the contents of E1 into the remaining E cells.

• Click on the curve for set B on the plot, and change the addresses of the y values to reflect
the offset Intensity data (in this example, change D's to E's).  

You should see the plot for set B jump to a higher position on the plot.  Just how high it appears
depends on the offset value.  You can always adjust the y-axis scale to get more vertical room, since
in a stacked plot the values on the y-axis are meaningless.  Repeat these steps for set C, using a larger
offset since you want it even higher on the plot.  

Finishing the plot:  

Because the y-axis values are meaningless in a stacked plot, you need to clean up the figure before
final presentation:

• Remove y-axis labels by double-clicking on the y-axis, and selecting none for axis, tick
marks, and tick mark lables.

• Remove the legend.  You can annotate the plot in MSWord when you paste it into your
document (use the View … Toolbars … Drawing toolbar at the bottom of the screen in
MSWord to apply text and arrows on top of the figure that you paste from Excel.)

V. Adding Y error bars to a plot using Excel

Be sure that there is a column containing the error in the y-axis values (k’ in this case) on the
spreadsheet that contains the plotted data.  To add error bars to the data points:

• Select the data set on the plot by clicking on a data point.
• Double click on the data point to bring up the Format Data Series dialog box.
• Click on the Y Error Bars tab.
• Click the Custom button, and place the cursor in the + window next to the button.

Highlight the column on the spreadsheet that contains the error in y.  Now place the cursor
in the – window next to the button, and again highlight the column on the spreadsheet that
contains the error in y.

• Be sure that the Both button is highlighted at the top of the dialog box, then click OK.

Vertical error bars should now be displayed on your plot.
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V. Printing the Spreadsheet

You will always need to hand in two hardcopies of your spreadsheet: one with numbers
displayed, and one with formulas displayed.  You may also want copies for yourself to keep with
your notebook.  The default option is view numbers.  If you want to view formulas, use the Tools
pull-down menu, choose Preferences, and click the View tab.  Select View Formulas in the
Window options.  ALL PRINTOUTS MUST INCLUDE ROW AND COLUMN HEADINGS.  To print
these, select Page Setup, click on the Sheet tab, and select Print row and column headings.

To get a preview of the way the spreadsheet will look on the page, go to Print Preview in
the File menu.  Please try to conserve paper and toner!  Change the orientation of the page to
landscape if it better fits your data.  You can also shrink the page by some percentage if you like, but
be sure that it remains readable.  If possible, fit the spreadsheet to one page.

You are responsible for keeping a good notebook for all experiments.  Be sure to document
your use of Excel clearly in your notebook, including your approach to solving the problem and any
calculations.  See also the section on keeping a good notebook (Notebooks and Reports).


